ViteSoft - Compartilhando tecnologia

Comunidade VSCyber free
Bem-vindo: Sex Jan 24, 2020 2:28 am

Todos os horários são GMT - 3 horas




Fórum trancado Este tópico está trancado. Você não pode responder ou editar mensagens.  [ 11 mensagens ]  Ir para página 1, 2  Próximo
Autor Mensagem
 Título: [Resolvido] Pedindo versão mais nova do Firebird
MensagemEnviado: Ter Out 25, 2011 11:31 am 
Offline
Estrelas
Estrelas

Registrado em: Dom Nov 19, 2006 6:19 pm
Mensagens: 706
Localização: SB/RS
Atualizei e ficou dando erro, pedindo versão mais nova do Firebird.
Desinstalei tudo, inclusive o FB e iniciei do zero... foi quando percebi que o banco atual é .fbd e antes era .gdb.
Trocar o banco não deu certo, tive que restaurar o banco. É assim mesmo?


Voltar ao topo
 Perfil  
 
 Título: Re: Atualize para a versão 3.2 Release Candidate
MensagemEnviado: Ter Out 25, 2011 11:37 am 
Offline
VSCyber Team
VSCyber Team

Registrado em: Sex Jul 14, 2006 7:52 pm
Mensagens: 11595
Localização: SC
Essa questão de pedir uma nova versão indica que o banco de dados foi utilizado por uma versão superior do Firebird em relação a atual. Por exemplo, já foi utilizado com o Firebird 2.1 e agora está instalado com o Firebird 1.5

_________________
Hovercraft
suporte@vitesoft.com
VSCYBER - Compartilhando Tecnologia
----------------------------------------

Pesquisa: A maneira mais rápida de obter suas respostas
Dica: marque a opção [Pesquisar por todos os termos]


Voltar ao topo
 Perfil  
 
 Título: Re: Pedindo versão mais nova do Firebird
MensagemEnviado: Ter Out 25, 2011 11:39 am 
Offline
VSCyber Team
VSCyber Team

Registrado em: Sex Jul 14, 2006 7:52 pm
Mensagens: 11595
Localização: SC
Tópico Dividido.

_________________
Hovercraft
suporte@vitesoft.com
VSCYBER - Compartilhando Tecnologia
----------------------------------------

Pesquisa: A maneira mais rápida de obter suas respostas
Dica: marque a opção [Pesquisar por todos os termos]


Voltar ao topo
 Perfil  
 
 Título: Re: Pedindo versão mais nova do Firebird
MensagemEnviado: Qua Out 26, 2011 10:37 am 
Offline
Estrelas
Estrelas

Registrado em: Dom Nov 19, 2006 6:19 pm
Mensagens: 706
Localização: SB/RS
Esse que é o problema, o banco é da versão 1.5 e foi colocado em outra máquina com a versão 2.x e fui no site do Firebird para colocar a última versão e continuou ocorrendo isso.
Mas resolvi, só achei estranho acontecer isso e a instalação da versão beta não fazer a correção automaticamente.


Voltar ao topo
 Perfil  
 
 Título: Re: Pedindo versão mais nova do Firebird
MensagemEnviado: Qua Out 26, 2011 10:46 am 
Offline
VSCyber Team
VSCyber Team

Registrado em: Sex Jul 14, 2006 7:52 pm
Mensagens: 11595
Localização: SC
Revern escreveu:
só achei estranho acontecer isso e a instalação da versão beta não fazer a correção automaticamente.

Desculpe mas não entendi essa parte.

O Firebird não permite que o banco de dados volte a ser manipulado por uma versão inferior do mesmo. Não entendi a relação com a versão beta.

_________________
Hovercraft
suporte@vitesoft.com
VSCYBER - Compartilhando Tecnologia
----------------------------------------

Pesquisa: A maneira mais rápida de obter suas respostas
Dica: marque a opção [Pesquisar por todos os termos]


Voltar ao topo
 Perfil  
 
 Título: Re: Pedindo versão mais nova do Firebird
MensagemEnviado: Sex Out 28, 2011 7:35 pm 
Offline
Estrelas
Estrelas

Registrado em: Dom Nov 19, 2006 6:19 pm
Mensagens: 706
Localização: SB/RS
Vou tentar ser mais claro

Meu banco estava rodando no FB 1.5, instalei a versão beta e não abria o banco (1.5).
Estava com o FB 2.0 depois de instalar a versão beta, então não deveria acontecer isso de pedir versão ainda mais nova, então eu atualizei para a mais atual vesão do site do FB, 2.5 se não me engano...
Continuou o problema de insisitir que o FB deveria se de versão ainda mais nova.
A solução que encontrei foi iniciar o sistema com o banco zerado, igual ao momento em que fazemos uma instalação e após isso eu recuperei um backup.

Quanto ao "só achei estranho acontecer isso e a instalação da versão beta não fazer a correção automaticamente." estava querendo dizer que entendia que ao instalar uma vesão nova do sistema o mesmo deveria efetuar automaticamente o backup e a recuperação, ou seja lá qual seja o procedimento possível para tornar o banco atual compatível com a nova versão do sistema. Veja bem, eu não usei um FB mais velho que aquele que estava rodando antes.


Voltar ao topo
 Perfil  
 
 Título: Re: Pedindo versão mais nova do Firebird
MensagemEnviado: Seg Out 31, 2011 9:09 am 
Offline
VSCyber Team
VSCyber Team

Registrado em: Sex Jul 14, 2006 7:52 pm
Mensagens: 11595
Localização: SC
Revern escreveu:
Meu banco estava rodando no FB 1.5, instalei a versão beta e não abria o banco (1.5).
Estava com o FB 2.0 depois de instalar a versão beta, então não deveria acontecer isso de pedir versão ainda mais nova, então eu atualizei para a mais atual vesão do site do FB, 2.5 se não me engano...

Anteriormente o VSCyber utiliza como referência a versão 1.5 do Firebird e depois passou a utilizar a versão 2.1 do Firebird, não passou por essa versão 2.0.

Revern escreveu:
Continuou o problema de insisitir que o FB deveria se de versão ainda mais nova.
A solução que encontrei foi iniciar o sistema com o banco zerado, igual ao momento em que fazemos uma instalação e após isso eu recuperei um backup.

O fato de instalar uma outra versão superior do Firebird, continua a utilizar os serviços da versão que estava antes. Nesse caso o processo mais fácil seria desinstalar a anterior e instalar a versão superior

Revern escreveu:
Quanto ao "só achei estranho acontecer isso e a instalação da versão beta não fazer a correção automaticamente." estava querendo dizer que entendia que ao instalar uma vesão nova do sistema o mesmo deveria efetuar automaticamente o backup e a recuperação, ou seja lá qual seja o procedimento possível para tornar o banco atual compatível com a nova versão do sistema. Veja bem, eu não usei um FB mais velho que aquele que estava rodando antes.

A atualização não realiza quaisquer alteração no banco de dados. (A menos que sejam necessário alterações no banco de dados, coisa que não ocorre desde a versão 2.6).

Por isso esse processo de backup e restauração não ocorre. A atualização consiste apenas em modifica os arquivos do VSCyber, ou seja, não são executados operações no banco de dados e nem no Firebird.

Tópico marcado como [Resolvido].

_________________
Hovercraft
suporte@vitesoft.com
VSCYBER - Compartilhando Tecnologia
----------------------------------------

Pesquisa: A maneira mais rápida de obter suas respostas
Dica: marque a opção [Pesquisar por todos os termos]


Voltar ao topo
 Perfil  
 
 Título: Re: [Resolvido] Pedindo versão mais nova do Firebird
MensagemEnviado: Qua Nov 02, 2011 7:22 pm 
Offline
Estrelas
Estrelas

Registrado em: Dom Nov 19, 2006 6:19 pm
Mensagens: 706
Localização: SB/RS
Mas notei que a extenção do arquivo de dados é diferente.
Agora é fdp e antes era gdb

Meu banco atual está rodando na versão 1.5 do FB, sem nada de problema e a versão do sistema é a 3.1sp1.

É instalar a versão mais nova, manter o banco de dados e ter a mensagem que a versão do FB exigida tem que ser mais nova e na instalação ele mesmo já instala a versão 2.0, porém, como falei antes, só funciona se eu fizer O que foi mencionado.

Bom, seja como for encontrei como fazer funcionar, mas se mais alguém tiver esse problema, já sabe como proceder. ;)


Voltar ao topo
 Perfil  
 
 Título: Re: [Resolvido] Pedindo versão mais nova do Firebird
MensagemEnviado: Qui Nov 03, 2011 9:58 am 
Offline
VSCyber Team
VSCyber Team

Registrado em: Sex Jul 14, 2006 7:52 pm
Mensagens: 11595
Localização: SC
Será que você não acabou instalando a nova versão ao invés de atualizar?

Pois o atualizar não leva junto o Firebird. Verifique se você executou a atualização através de um dos processos abaixo?
http://www.vscyber.com/wiki/index.php/A ... %A7%C3%A3o

_________________
Hovercraft
suporte@vitesoft.com
VSCYBER - Compartilhando Tecnologia
----------------------------------------

Pesquisa: A maneira mais rápida de obter suas respostas
Dica: marque a opção [Pesquisar por todos os termos]


Voltar ao topo
 Perfil  
 
 Título: Re: [Resolvido] Pedindo versão mais nova do Firebird
MensagemEnviado: Seg Nov 07, 2011 3:41 pm 
Offline
Estrelas
Estrelas

Registrado em: Dom Nov 19, 2006 6:19 pm
Mensagens: 706
Localização: SB/RS
Baixei o setup da versao beta 3, instalei por cima da versão anterior e deu problema.
Removi tudo, VSCyber e FB, instalei do zero e rodou o sistema normalmente, foi instalado o FB durante a instalação do VSCyber.
Quando fui utilizar o BD atual da loja, o problema apareceu informando que a necessitava de versão mais nova do FB, foi então que comecei instalar tudo que era versão do FB sem resolver.
Depois de um tempo percebi que a instalação zerada havia gerado um BD com outra extenção, chegando a solução como mencionado acima.


Voltar ao topo
 Perfil  
 
Exibir mensagens anteriores:  Ordenar por  
Fórum trancado Este tópico está trancado. Você não pode responder ou editar mensagens.  [ 11 mensagens ]  Ir para página 1, 2  Próximo

Todos os horários são GMT - 3 horas


Quem está online

Usuários navegando neste fórum: Nenhum usuário registrado e 3 visitantes


Enviar mensagens: Proibido
Responder mensagens: Proibido
Editar mensagens: Proibido
Excluir mensagens: Proibido
Enviar anexos: Proibido

Procurar por:
Powered by phpBB® Forum Software © phpBB Group
Traduzido por: Suporte phpBB